I’m sure most ESRI customers received the following email from ESRI regarding the Oracle 10.2.0.4 patch and ArcSDE:

If you are a user of the ArcGIS Server 9.2 ST_GEOMETRY data type with Oracle, we would like to make you aware of the following issue:

The recently released Oracle patch version 10.2.0.4 may make unexpected changes to the ST_GEOMETRY schema. ESRI is in contact with Oracle, and we are working together to understand and quickly resolve the problem in this Oracle 10.2.0.4 patch upgrade.

ESRI strongly recommends that all Oracle-based customers not upgrade to the Oracle 10.2.0.4 patch until ESRI has certified this Oracle patch release with ArcGIS Server 9.2.

If you have already upgraded to Oracle 10.2.0.4 and think you may be experiencing this issue, contact ESRI Support.

What is humorous about the whole issue (well at least funny to those not caught up in it) is that Oracle includes the following statement on their readme for 10.2.0.4 patch.

“Patch sets are a mechanism for delivering fully tested and integrated product fixes. Patch sets provide bug fixes only; they do not include new functionality and they do not require certification on the target system.”

Guess that isn’t the case, eh Oracle?

Oracle

It seems that every time we meet, I have nothing but bad news. I’m sorry about that, I surely am.