ESRI is about to release an update to ArcGIS Explorer. Build 450 will add no new features, but will resolve a number of graphics card related issues that we inadvertently picked up at 440 (via ArcGlobe apparently). There has been some discussion in the ESRI forums about this issue:

This problem was introduced by OpenGL call changes in ArcGIS Explorer 440. Some have found that ArcGIS Explorer 410 worked, while version 440 does not. In general the problem does not occur with newer graphics cards and new drivers.

a. Potential resolution. Install the latest driver for your graphics card from your graphics card or hardware vendor.

b. Here are some specific observations in regards to graphics cards.

i. ATI FireGL V3100 ‘ 8650 will work with the latest driver from AMD. Driver Packaging Version 8.44

ii. ATI Mobility FireGL Latest drivers from vendor do not appear to fix issue. We are working on an ArcGIS Explorer update to address this.Keep an eye out on the ArcGIS Explorer blog for the release.