So the news at the DevSummit was that you could install both ArcGIS 9.4 alongside ArcGIS 9.3.1. I’m not part of the beta for 9.4, but reports are that ESRI has not enabled this yet for the latest 9.4 beta release. If you want to install 9.4 on a computer running ArcGIS 9.3.1, you are being prompted to uninstall 9.3.1 before continuing. Has anyone yet been able to run 9.4 and 9.3.1 at the same time?

Now this could be a limitation of the current beta and not actually any retreat by ESRI on being able to run two versions of ArcGIS on the same machine. Either way it make it really hard to beta test the 9.4 release as you can’t compare it to older versions.

Note: If you post any specific 9.4 Beta information (such as quoting forums posts on the Beta forums), expect ESRI to personally contact you. They appear to be monitoring this blog post. You’ve been warned.